Tux Guitar

Problems

Subject Debian etch no sound problem :(



Author Message
xAmyx
Post: Mar 15th 2008 at 8:20 PM

Hi there!

I have a small problem. Im running under debian arch 4.0 and I've just installed tuxguitar from file: tuxguitar-1.0-rc2-linux-installer.bin
My problem is: when I do ./tuxguitar in the console I get this:

org.herac.tuxguitar.gui.system.plugins.TGPluginException: Java sound api cannot be loaded
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.addPluin(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGPluginList.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.TGPluginManager.openPlugins(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Caused by: org.herac.tuxguitar.player.base.MidiPlayerException: Java sound api cannot be loaded
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortProviderImpl.listPorts(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.addPortProvider(Unknown Source) at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.addPluin(Unknown Source)
...5 more
Caused by: java.lang.UnsatisfiedLinkError: init_
at gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider.init_(libgcj.so.70)
at gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider.(libgcj.so.70)
at java.lang.Class.initializeClass(libgcj.so.70)
at java.lang.Class.newInstance(libgcj.so.70)
at gnu.classpath.ServiceProviderLoadingAction.run(libgcj.so.70)
at java.security.AccessController.doPrivileged(libgcj.so.70)
at gnu.classpath.ServiceFactory$ServiceIterator.loadNextServiceProvider(libgcj.so.70)
at gnu.classpath.ServiceFactory$ServiceIterator.(libgcj.so.70)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.70)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.70)
at javax.sound.midi.MidiSystem.getMidiDeviceInfo(libgcj.so.70)
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortProviderImpl.listPorts(Unknown Source)
...7 more
org.herac.tuxguitar.gui.system.plugins.TGPluginException: An error ocurred when trying to set plugin status
at org.herac.tuxguitar.gui.system.plugins.TGPluginManager.openPlugins(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Caused by: java.lang.UnsatisfiedLinkError: libtuxguitar-alsa-jni: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by lib/libtuxguitar-alsa-jni.so)
at java.lang.Runtime._load(libgcj.so.70)
at java.lang.Runtime.loadLibrary(libgcj.so.70)
at java.lang.System.loadLibrary(libgcj.so.70)
at org.herac.tuxguitar.player.impl.midiport.alsa.JNILibraryLoader.loadLibrary(Unknown Source)
at org.herac.tuxguitar.player.impl.midiport.alsa.MidiSystem.(Unknown Source)
at java.lang.Class.initializeClass(libgcj.so.70)
at org.herac.tuxguitar.player.impl.midiport.alsa.MidiPortProviderImpl.listPorts(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.addPortProvider(Unknown Source) at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.addPluin(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.TGPluginManager.openPlugins(Unknown Source)
...2 more


Than when Tux's windows opens, two bubbles pops up saying:
"An error ocurred when trying to set plugin status"
and
"Java sound api cannot be loadedd"

Which makes me sad because few days ago I installed Java version 1.06 from page: http://www.java.com/en/download/help/5000010500.xml#selfextracting
and havent got any problems with running java aplications :(
Is there a way to fix it? What did I do wrong? I would really appreciate it if someone could help me and explain me whats wrong.

XXXX

Amy


Back to Top
 
Johnny
Post: Mar 15th 2008 at 9:48 PM

Try to type "java -version" in your console, I bet your Sun JVM is installed, but isn't set as default JVM.

Whatever causes the problem, the result is that you cannot load TuxGuitar-jsa plugin. TuxGuitar-alsa plugin should work very well (go to Sound Properties).


Back to Top
 
xAmyx
Post: Mar 15th 2008 at 10:19 PM

java -version gave this:
java version "1.4.2"
gij (GNU libgcj) version 4.1.2 20061115 (prerelease) (Debian 4.1.1-20)

Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


How can I set it as default? And where I can download this TuxGuitar-alsa plugin? By going to Sound Properties you mean Tools/Setting/Sound in the main tuxguitar window, yes? Well there's only MIDI Sequencer in which TuxGuitar Sequencer is selected and MIDI Port which is blank, nothing more about plugins


Back to Top
 
Johnny
Post: Mar 15th 2008 at 11:44 PM

I don't know how to easily set defaults in Arch, I know in Ubuntu the script is /etc/alternatives/java. Anyway, executable called "java" is somewhere in your path, probably a symbolic link, so you can change it.

TuxGuitar-alsa is now distributed with RC1 and RC2 versions... So if you got TG week ago or sooner, it should be inside your distribution. Download it again, that's the easiest way.


Back to Top
 
vtvitus
Post: Mar 16th 2008 at 6:08 PM

Debian has old glibc 2.3.6. tuxguitar alsa plugin compiled with glibc 2.4.0. You may download tuxguitar src and compile alsa so module - it's easy if you have jvm :).

cd tuxguitar-src-1.0-rc2/TuxGuitar-alsa/jni/

export JAVA_HOME=path_to_java (for example: export JAVA_HOME=/usr/lib/jvm/java-1.5.0-sun-1.5.0.14 )

make LIBRARY_PREFIX=libtuxguitar LIBRARY_NAME=-alsa-jni LIBRARY_EXTENSION=.so

cp libtuxguitar-alsa-jni.so path_where_tuxguitar_install/lib/libtuxguitar-alsa-jni.so

run tuxguitar. +)
for midi emul install timidity && freepats ( apt-get install timidity freepats ).


Back to Top
 
Anonymous
Post: Mar 17th 2008 at 7:02 PM

@vtvitus:

one silly question: where I can download tuxguitar src? I dont see it in the Download section on the main page.


Back to Top
 
xAmyx
Post: Mar 17th 2008 at 7:02 PM

That was me btw!


Back to Top
 
Julian
Post: Mar 17th 2008 at 7:19 PM

Is the first link on the download page:

Latest Version 1.0-rc2

Get TuxGuitar "sources" now or ....

click on sources and you'll go to this link:
http://downloads.sourceforge.net/tuxguitar/tuxguitar-src-1.0-rc2.tar.gz


Back to Top
 
xAmyx
Post: Mar 17th 2008 at 8:09 PM

Oh silly me! Thank you!


Back to Top
 
xAmyx
Post: Mar 17th 2008 at 9:08 PM

@vtvitus: I did it just like you said:
export JAVA_HOME=/usr/java/jre1.6.0_05/
make LIBRARY_PREFIX=libtuxguitar LIBRARY_NAME=-alsa-jni LIBRARY_EXTENSION=.so

but it returned me quite alot errors like:
xist.
[javac] org/herac/tuxguitar/gui/marker/MarkerNavigator.java added as org/herac/tuxguitar/gui/marker/MarkerNavigator.class doesn't exist.
[javac] org/herac/tuxguitar/gui/mixer/TGMixer.java added as org/herac/tuxguitar/gui/mixer/TGMixer.class doesn't exist.
[javac] org/herac/tuxguitar/gui/mixer/TGMixerTrack.java added as org/herac/tuxguitar/gui/mixer/TGMixerTrack.class doesn't exist.
[javac] org/herac/tuxguitar/gui/mixer/TGMixerTrackChannel.java added as org/herac/tuxguitar/gui/mixer/TGMixerTrackChannel.class doesn't exist.
[javac] org/herac/tuxguitar/gui/printer/PrintDocument.java added as org/herac/tuxguitar/gui/printer/PrintDocument.class doesn't exist.
[javac] org/herac/tuxguitar/gui/printer/PrintDocumentData.java added as org/herac/tuxguitar/gui/printer/PrintDocumentData.class doesn't exist.
[javac] org/herac/tuxguitar/gui/printer/PrintPage.java added as org/herac/tuxguitar/gui/printer/PrintPage.class doesn't exist.
[javac] org/herac/tuxguitar/gui/printer/PrintPreview.java added as org/herac/tuxguitar/gui/printer/PrintPreview.class doesn't exist.
[javac] org/herac/tuxguitar/gui/system/config/TGConfigDefaults.java added as org/herac/tuxguitar/gui/system/config/TGConfigDefaults.class doesn't exist.
[javac] org/herac/tuxguitar/gui/system/config/TGConfigEditor.java added as org/herac/tuxguitar/gui/system/config/TGConfigEditor.class doesn't exist.
[javac] org/herac/tuxguitar/gui/system/config/TGConfigKeys.java added as org/herac/tuxguitar/gui/system/config/TGConfigKeys.class doesn't exist.
[javac] org/herac/tuxguitar/gui/system/config/TGConfigManager.java added as org/herac/tuxguitar/gui/system/config/TGConfigManager.class doesn't exist.
[javac] org/herac/tuxguitar/gui/system/config/TGConfigManagerImpl.java added as org/herac/tuxguitar/gui/system/config/TGConfigManagerImpl.class doesn't exist.
[javac] org/herac/tuxguitar/gui/system/config/items/LanguageOption.java added as org/herac/tuxguitar/gui/system/config/items/LanguageOption.class doesn't exist.
[javac] org/herac/tuxguitar/gui/system/config/items/MainOption.java added as org/herac/tuxguitar/gui/system/config/items/MainOption.class doesn't exist.
[javac] org/herac/tuxguitar/gui/system/config/items/Option.java added as org/herac/tuxguitar/gui/system/config/items/Option.class doesn't exist.
[javac] org/herac/tuxguitar/gui/system/config/items/SkinOption.java added as org/herac/tuxguitar/gui/system/config/items/SkinOption.class doesn't exist.

and ended with:
BUILD FAILED
/home/j/Desktop/tuxguitar-src-1.0-rc2/TuxGuitar/build.xml:24: The following error occurred while executing this line:
/home/j/Desktop/tuxguitar-src-1.0-rc2/TuxGuitar/build.xml:42: /usr/lib/java not found.
at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:539)
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:385)
at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:107)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
at org.apache.tools.ant.Task.perform(Task.java:364)
at org.apache.tools.ant.Target.execute(Target.java:341)
at org.apache.tools.ant.Target.performTasks(Target.java:369)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
at org.apache.tools.ant.Main.runBuild(Main.java:668)
at org.apache.tools.ant.Main.startAnt(Main.java:187)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)
Caused by: /home/j/Desktop/tuxguitar-src-1.0-rc2/TuxGuitar/build.xml:42: /usr/lib/java not found.
at org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileSet.java:349)
at org.apache.tools.ant.types.Path.list(Path.java:336)
at org.apache.tools.ant.types.Path.list(Path.java:325)
at org.apache.tools.ant.types.Path.list(Path.java:325)
at org.apache.tools.ant.types.Path.addExisting(Path.java:258)
at org.apache.tools.ant.types.Path.addExisting(Path.java:247)
at org.apache.tools.ant.types.Path.concatSystemClasspath(Path.java:564)
at org.apache.tools.ant.taskdefs.compilers.DefaultCompilerAdapter.getCompileClasspath(DefaultCompilerAdapter.java:141)
at org.apache.tools.ant.taskdefs.compilers.DefaultCompilerAdapter.setupJavacCommandlineSwitches(DefaultCompilerAdapter.java:163)
at org.apache.tools.ant.taskdefs.compilers.DefaultCompilerAdapter.setupModernJavacCommandlineSwitches(DefaultCompilerAdapter.java:296)
at org.apache.tools.ant.taskdefs.compilers.DefaultCompilerAdapter.setupModernJavacCommand(DefaultCompilerAdapter.java:341)
at org.apache.tools.ant.taskdefs.compilers.Javac13.execute(Javac13.java:47)
at org.apache.tools.ant.taskdefs.Javac.compile(Javac.java:931)
at org.apache.tools.ant.taskdefs.Javac.execute(Javac.java:757)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
at org.apache.tools.ant.Task.perform(Task.java:364)
at org.apache.tools.ant.Target.execute(Target.java:341)
at org.apache.tools.ant.Target.performTasks(Target.java:369)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:37)
at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:382)
... 13 more
--- Nested Exception ---
/home/j/Desktop/tuxguitar-src-1.0-rc2/TuxGuitar/build.xml:42: /usr/lib/java not found.
at org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileSet.java:349)
at org.apache.tools.ant.types.Path.list(Path.java:336)
at org.apache.tools.ant.types.Path.list(Path.java:325)
at org.apache.tools.ant.types.Path.list(Path.java:325)
at org.apache.tools.ant.types.Path.addExisting(Path.java:258)
at org.apache.tools.ant.types.Path.addExisting(Path.java:247)
at org.apache.tools.ant.types.Path.concatSystemClasspath(Path.java:564)
at org.apache.tools.ant.taskdefs.compilers.DefaultCompilerAdapter.getCompileClasspath(DefaultCompilerAdapter.java:141)
at org.apache.tools.ant.taskdefs.compilers.DefaultCompilerAdapter.setupJavacCommandlineSwitches(DefaultCompilerAdapter.java:163)
at org.apache.tools.ant.taskdefs.compilers.DefaultCompilerAdapter.setupModernJavacCommandlineSwitches(DefaultCompilerAdapter.java:296)
at org.apache.tools.ant.taskdefs.compilers.DefaultCompilerAdapter.setupModernJavacCommand(DefaultCompilerAdapter.java:341)
at org.apache.tools.ant.taskdefs.compilers.Javac13.execute(Javac13.java:47)
at org.apache.tools.ant.taskdefs.Javac.compile(Javac.java:931)
at org.apache.tools.ant.taskdefs.Javac.execute(Javac.java:757)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
at org.apache.tools.ant.Task.perform(Task.java:364)
at org.apache.tools.ant.Target.execute(Target.java:341)
at org.apache.tools.ant.Target.performTasks(Target.java:369)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:37)
at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:382)
at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:107)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
at org.apache.tools.ant.Task.perform(Task.java:364)
at org.apache.tools.ant.Target.execute(Target.java:341)
at org.apache.tools.ant.Target.performTasks(Target.java:369)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
at org.apache.tools.ant.Main.runBuild(Main.java:668)
at org.apache.tools.ant.Main.startAnt(Main.java:187)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)

Total time: 19 seconds
make: *** [TuxGuitar/tuxguitar.jar] Error 1

Im hopeless :(


Back to Top
 
Julian
Post: Mar 17th 2008 at 9:33 PM

Hi, "vtvitus" told you how to build tuxguitar-alsa native library. but it seems you exec "make" on the main sources folder.

go to "/TuxGuitar-alsa/jni" folder and then do what "vtvitus" told you.


Back to Top
 
xAmyx
Post: Mar 17th 2008 at 9:42 PM

Ok I did it, heres what showed up:

debian:/home/j/Desktop/tuxguitar-src-1.0-rc2/TuxGuitar-alsa/jni# export JAVA_HOME=/usr/java/jre1.6.0_05/ debian:/home/j/Desktop/tuxguitar-src-1.0-rc2/TuxGuitar-alsa/jni# make LIBRARY_PREFIX=libtuxguitar LIBRARY_NAME=-alsa-jni LIBRARY_EXTENSION=.so
gcc -fPIC -I /usr/java/jre1.6.0_05//include/ -I /usr/java/jre1.6.0_05//include/linux/ -c -o org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.o org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c
In file included from org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:4:
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:2:17: error: jni.h: No such file or directory
In file included from org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:4:
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘jlong’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:23: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:31: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:39: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:47: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:55: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:63: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:71: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:79: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:87: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:95: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.h:103: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:12: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘jlong’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:25: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:34: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:57: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:67: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:102: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:115: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:126: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:143: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:160: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:177: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.c:194: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
make: *** [org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem.o] Error 1
debian:/home/j/Desktop/tuxguitar-src-1.0-rc2/TuxGuitar-alsa/jni#


Back to Top
 
Julian
Post: Mar 17th 2008 at 9:49 PM

Ok, but do you have JDK ??
it seems you have only the JRE installed.
check if this folder exists:
/usr/java/jre1.6.0_05/include/

you'll need also libasound devel package installed.


Back to Top
 
xAmyx
Post: Mar 17th 2008 at 10:41 PM

OMG! I've just downloaded the developers version of java and installed it. Than I did what mister vtvitus said and ...it worked! :) I cant describe how thankful I am. Thank you very much!

Amy


Back to Top
 
vtvitus
Post: Mar 18th 2008 at 8:00 PM

>it worked! :)

It's a kind of magic :)


Back to Top